summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <gerd@gnu.org>2000-11-20 14:07:03 +0000
committerGerd Moellmann <gerd@gnu.org>2000-11-20 14:07:03 +0000
commit5650262f75fc6f0de8730ef2f560bace0ae7a16a (patch)
tree70e0d9e883c18ccd907ce52fc9be6293ba6af8e7 /configure.in
parent75eee30de91b11a849c3022dde9348028ddb7c21 (diff)
downloademacs-5650262f75fc6f0de8730ef2f560bace0ae7a16a.tar.gz
Use -traditional with GNU cpp.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e83b81f1883..341711dc648 100644
--- a/configure.in
+++ b/configure.in
@@ -2257,6 +2257,13 @@ changequote([, ])dnl
echo creating src/epaths.h
make epaths-force
+# As of 2000-11-19, newest development versions of GNU cpp preprocess
+# `..' to `. .' unless invoked with -traditional
+
+if [ x$GCC = xyes && x$NON_GNU_CPP" = x ]; then
+ CPPFLAGS="$CPPFLAGS -traditional"
+fi
+
echo creating lib-src/Makefile
( cd lib-src
rm -f junk.c junk1.c junk2.c