summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2000-03-08 18:40:13 +0000
committerDave Love <fx@gnu.org>2000-03-08 18:40:13 +0000
commit3f5b097c6db746db99934853c6744a1e1664094d (patch)
tree092aced7d342ca686a47fc83cedc19ef41d90277 /configure.in
parent308a47937d35bf133668a032dcf922e59980b788 (diff)
downloademacs-3f5b097c6db746db99934853c6744a1e1664094d.tar.gz
Use AC_PROG_RANLIB, AC_C_PROTOTYPES, AC_C_VOLATILE. Define
POINTER_TYPE.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 22 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 639d4444cf2..52ab1e570b0 100644
--- a/configure.in
+++ b/configure.in
@@ -3,7 +3,7 @@ dnl To rebuild the `configure' script from this, execute the command
dnl autoconf
dnl in the directory containing this script.
dnl
-dnl Copyright (C) 1994, 1995, 1996, 1999 Free Software Foundation, Inc.
+dnl Copyright (C) 1994, 1995, 1996, 1999, 2000 Free Software Foundation, Inc.
dnl
dnl This file is part of GNU Emacs.
dnl
@@ -1062,10 +1062,6 @@ if test x"${opsys}" = x; then
esac
fi
-if test "x$RANLIB" = x; then
- RANLIB=ranlib
-fi
-
changequote([, ])dnl
if test $unported = yes; then
@@ -1140,6 +1136,9 @@ AC_PROG_LN_S
AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_YACC
+if test "x$RANLIB" = x; then
+ AC_PROG_RANLIB
+fi
dnl checks for Unix variants
AC_AIX
@@ -1207,7 +1206,25 @@ if test $emacs_cv_tm_gmtoff = yes; then
fi
dnl checks for compiler characteristics
+
+dnl Testing __STDC__ to determine prototype support isn't good enough.
+dnl DEC C, for instance, doesn't define it with default options, and
+dnl is used on 64-bit systems (OSF Alphas). Similarly for volatile
+dnl and void *.
+AC_C_PROTOTYPES
+AC_C_VOLATILE
AC_C_CONST
+dnl This isn't useful because we can't turn on use of `inline' unless
+dnl the compiler groks `extern inline'.
+dnl AC_C_INLINE
+AC_CACHE_CHECK([for void * support], emacs_cv_void_star,
+ [AC_TRY_COMPILE(, [void * foo;],
+ emacs_cv_void_star=yes, emacs_cv_void_star=no)])
+if test $emacs_cv_void_star = yes; then
+ AC_DEFINE(POINTER_TYPE, void)
+else
+ AC_DEFINE(POINTER_TYPE, char)
+fi
dnl check for Make feature
AC_PROG_MAKE_SET
@@ -2003,7 +2020,6 @@ AC_SUBST(CFLAGS)
AC_SUBST(X_TOOLKIT_TYPE)
AC_SUBST(machfile)
AC_SUBST(opsysfile)
-AC_SUBST(RANLIB)
AC_DEFINE_UNQUOTED(EMACS_CONFIGURATION, "${canonical}")
AC_DEFINE_UNQUOTED(EMACS_CONFIG_OPTIONS, "${ac_configure_args}")