summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMiles Bader <miles@gnu.org>2007-07-15 02:05:20 +0000
committerMiles Bader <miles@gnu.org>2007-07-15 02:05:20 +0000
commit7eb1e4534e88a32fe5e549e630fdabf3e062be2b (patch)
tree34fc72789f1cfbfeb067cf507f8871c322df300a /configure.in
parent76d11d2cf9623e9f4c38e8239c4444ffc1fae485 (diff)
parent6f8a87c027ebd6f9cfdac5c0df97d651227bec62 (diff)
downloademacs-7eb1e4534e88a32fe5e549e630fdabf3e062be2b.tar.gz
Merge from emacs--devo--0
Patches applied: * emacs--devo--0 (patch 803-813) - Update from CVS - Merge from emacs--rel--22 * emacs--rel--22 (patch 51-58) - Update from CVS - Merge from gnus--rel--5.10 * gnus--rel--5.10 (patch 233-236) - Merge from emacs--devo--0 - Update from CVS Revision: emacs@sv.gnu.org/emacs--multi-tty--0--patch-25
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 25 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 768e401cccf..0952d113b70 100644
--- a/configure.in
+++ b/configure.in
@@ -105,7 +105,7 @@ AC_ARG_WITH(jpeg,
AC_ARG_WITH(tiff,
[ --with-tiff use -ltiff for displaying TIFF images])
AC_ARG_WITH(gif,
-[ --with-gif use -lungif (or -lgif) for displaying GIF images])
+[ --with-gif use -lgif (or -lungif) for displaying GIF images])
AC_ARG_WITH(png,
[ --with-png use -lpng for displaying PNG images])
AC_ARG_WITH(gpm,
@@ -1892,6 +1892,22 @@ dnl use the toolkit if we have gtk, or X11R5 or newer.
;;
esac
+if test "$window_system" = none && test "X$with_x" != "Xno"; then
+ AC_CHECK_PROG(HAVE_XSERVER, X, true, false)
+ if test "$HAVE_XSERVER" = true ||
+ test -n "$DISPLAY" ||
+ test "`echo /usr/lib/libX11.*`" != "/usr/lib/libX11.*"; then
+ AC_MSG_ERROR([You seem to be running X, but no X development libraries
+were found. You should install the relevant development files for X
+and for the toolkit you want, such as Gtk+, Lesstif or Motif. Also make
+sure you have development files for image handling, i.e.
+tiff, gif, jpeg, png and xpm.
+If you are sure you want Emacs compiled without X window support, pass
+ --without-x
+to configure.])
+ fi
+fi
+
### If we're using X11, we should use the X menu package.
HAVE_MENUS=no
case ${HAVE_X11} in
@@ -2528,24 +2544,24 @@ if test "${HAVE_X11}" = "yes" && test "${with_gif}" != "no"; then
AC_CHECK_HEADER(gif_lib.h,
# EGifPutExtensionLast only exists from version libungif-4.1.0b1.
# Earlier versions can crash Emacs.
- AC_CHECK_LIB(ungif, EGifPutExtensionLast, HAVE_GIF=yes, try_libgif=yes))
+ AC_CHECK_LIB(gif, EGifPutExtensionLast, HAVE_GIF=yes, try_libungif=yes))
if test "$HAVE_GIF" = yes; then
- ac_gif_lib_name="-lungif"
+ ac_gif_lib_name="-lgif"
fi
-# If gif_lib.h but no libungif, try libgif.
- if test x"$try_libgif" = xyes; then
- AC_CHECK_LIB(gif, EGifPutExtensionLast, HAVE_GIF=yes)
+# If gif_lib.h but no libgif, try libungif.
+ if test x"$try_libungif" = xyes; then
+ AC_CHECK_LIB(ungif, EGifPutExtensionLast, HAVE_GIF=yes)
if test "$HAVE_GIF" = yes; then
- AC_DEFINE(LIBGIF, -lgif, [Compiler option to link with the gif library (if not -lungif).])
- ac_gif_lib_name="-lgif"
+ AC_DEFINE(LIBGIF, -lungif, [Compiler option to link with the gif library (if not -lgif).])
+ ac_gif_lib_name="-lungif"
fi
fi
if test "${HAVE_GIF}" = "yes"; then
- AC_DEFINE(HAVE_GIF, 1, [Define to 1 if you have a gif library (default -lungif; otherwise specify with LIBGIF).])
+ AC_DEFINE(HAVE_GIF, 1, [Define to 1 if you have a gif library (default -lgif; otherwise specify with LIBGIF).])
fi
fi