summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChong Yidong <cyd@stupidchicken.com>2011-01-11 21:29:23 -0500
committerChong Yidong <cyd@stupidchicken.com>2011-01-11 21:29:23 -0500
commit70ba1ec80ca6b9f2c649b381e9882b5378943929 (patch)
treea6fa18ea10775658648bbc03ae18fc32140adb5f /configure.in
parentba404aa123cccfd4d73d53a1309b6d570ffea2a2 (diff)
downloademacs-70ba1ec80ca6b9f2c649b381e9882b5378943929.tar.gz
Distinguish between terminfo and termcap on NetBSD (Bug#7642).
* configure.in [netbsd systems]: Check for tputs definition. * src/config.in (TERMINFO): New definition. * src/s/netbsd.h: Use it to choose between terminfo and termcap.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2cbd03067db..b15a0bf7a7f 100644
--- a/configure.in
+++ b/configure.in
@@ -2372,6 +2372,15 @@ AC_CHECK_FUNCS(getpt)
# than to expect to find it in ncurses.
AC_CHECK_LIB(ncurses, tparm)
+case "$opsys" in
+ netbsd)
+ AC_SEARCH_LIBS(tputs, [ncurses terminfo termcap])
+ if test $ac_cv_search_tputs = -lterminfo; then
+ AC_DEFINE(TERMINFO, 1, [Define to 1 if you use terminfo instead of termcap.])
+ fi
+ ;;
+esac
+
# Do we have res_init, for detecting changes in /etc/resolv.conf?
resolv=no