summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2007-09-12 07:03:30 +0000
committerGlenn Morris <rgm@gnu.org>2007-09-12 07:03:30 +0000
commit4756ee429c7e52444f1d8ae4629db9327411e048 (patch)
tree2968f6f255f8ca61cb9c395d8ddb9aaedade574d /configure.in
parent5a6a83f216e499e598bc95d2ae6b820ae004ea6c (diff)
downloademacs-4756ee429c7e52444f1d8ae4629db9327411e048.tar.gz
(AC_FUNC_ALLOCA): Throw an error if a system implementation of alloca
is not found.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c873a290020..306f8441973 100644
--- a/configure.in
+++ b/configure.in
@@ -2692,6 +2692,13 @@ fi
AC_FUNC_ALLOCA
+dnl src/alloca.c has been removed. Could also check if $ALLOCA is set?
+dnl FIXME is there an autoconf test that does the right thing, without
+dnl needing to call A_M_E afterwards?
+if test x"$ac_cv_func_alloca_works" != xyes; then
+ AC_MSG_ERROR( [a system implementation of alloca is required] )
+fi
+
# fmod, logb, and frexp are found in -lm on most systems.
# On HPUX 9.01, -lm does not contain logb, so check for sqrt.
AC_CHECK_LIB(m, sqrt)