summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2012-05-16 22:32:37 -0700
committerGlenn Morris <rgm@gnu.org>2012-05-16 22:32:37 -0700
commitb4a3620021f85b50a24a739a55f85fc8cc876be7 (patch)
tree99f3b45bb86f379ab35f2587d01ae911621c1142 /configure.in
parent96182ae6973a088e7c3fffd489acf626d0b3a6cb (diff)
downloademacs-b4a3620021f85b50a24a739a55f85fc8cc876be7.tar.gz
Fix previous change, for NS builds that are not self-contained
* configure.in (ns_self_contained): New output variable. * Makefile.in (ns_self_contained): New, set by configure. (install-arch-dep): Use $ns_self_contained.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8c3b3228241..048a8d7dec4 100644
--- a/configure.in
+++ b/configure.in
@@ -1574,6 +1574,7 @@ fi
AC_SUBST(TEMACS_LDFLAGS2)
LEIM_INSTALLDIR="\${install_prefix}/leim"
+ns_self_contained=no
ns_frag=/dev/null
NS_OBJ=
NS_OBJC_OBJ=
@@ -1586,6 +1587,7 @@ if test "${HAVE_NS}" = yes; then
with_xft=no
# set up packaging dirs
if test "${EN_NS_SELF_CONTAINED}" = yes; then
+ ns_self_contained=yes
prefix=${ns_appresdir}
exec_prefix=${ns_appbindir}
dnl This one isn't really used, only archlibdir is.
@@ -1600,6 +1602,7 @@ fi
CFLAGS="$tmp_CFLAGS"
CPPFLAGS="$tmp_CPPFLAGS"
AC_SUBST(LEIM_INSTALLDIR)
+AC_SUBST(ns_self_contained)
AC_SUBST(NS_OBJ)
AC_SUBST(NS_OBJC_OBJ)
AC_SUBST(LIB_STANDARD)