summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDan Nicolaescu <dann@ics.uci.edu>2010-10-10 08:35:04 -0700
committerDan Nicolaescu <dann@ics.uci.edu>2010-10-10 08:35:04 -0700
commita4daeecfef2bf5822f2b514b2878391b90edf741 (patch)
treeb099f5110bc376c1b4b584112d569e00f870a0db /configure.in
parent4cf3ad3065d38ec51d6da12d50a83d96860f7db8 (diff)
downloademacs-a4daeecfef2bf5822f2b514b2878391b90edf741.tar.gz
Pass CFLAGS to the linker.
* configure.in (PROFILING_LDFLAGS): Do not define, remove all uses. * lib-src/Makefile.in (PROFILING_LDFLAGS): Remove, not needed. * msdos/sed1v2.inp (PROFILING_LDFLAGS): * msdos/sed3v2.inp (PROFILING_LDFLAGS): Remove, not defined anymore. * src/Makefile.in (temacs): Use $(ALL_CFLAGS) on the link line. (PROFILING_LDFLAGS): Remove, not needed anymore.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 51d70121280..506732413ae 100644
--- a/configure.in
+++ b/configure.in
@@ -325,13 +325,10 @@ AC_ARG_ENABLE(profiling,
[ac_enable_profiling="${enableval}"],[])
if test x$ac_enable_profiling != x ; then
PROFILING_CFLAGS="-DPROFILING=1 -pg"
- PROFILING_LDFLAGS="-pg"
else
PROFILING_CFLAGS=
- PROFILING_LDFLAGS=
fi
AC_SUBST(PROFILING_CFLAGS)
-AC_SUBST(PROFILING_LDFLAGS)
AC_ARG_ENABLE(autodepend,
[AS_HELP_STRING([--enable-autodepend],
@@ -1487,7 +1484,7 @@ tmp_CPPFLAGS="$CPPFLAGS"
tmp_CFLAGS="$CFLAGS"
CPPFLAGS="$CPPFLAGS -x objective-c"
CFLAGS="$CFLAGS -x objective-c"
-TEMACS_LDFLAGS2="\${LDFLAGS} \${PROFILING_LDFLAGS}"
+TEMACS_LDFLAGS2="\${LDFLAGS}"
dnl I don't think it's especially important, but src/Makefile.in
dnl (now the only user of ns_appdir) used to go to the trouble of adding a
dnl trailing "/" to it, so now we do it here.