summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2012-06-24 10:39:14 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2012-06-24 10:39:14 -0700
commit845ca893904e4664063cb5c121b34925386849f7 (patch)
tree6d9798a0d167f9e6bb5a2a6dae21c83ad9eb9a74 /configure.in
parent696056c280e0e4a03e12d8d53f692c015ff19217 (diff)
downloademacs-845ca893904e4664063cb5c121b34925386849f7.tar.gz
Switch from NO_RETURN to C11's _Noreturn.
Fixes: debbugs:11750
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 4c3316a0d3b..1115486b2ef 100644
--- a/configure.in
+++ b/configure.in
@@ -3536,13 +3536,6 @@ AH_BOTTOM([
#include <string.h>
#include <stdlib.h>
-#if defined __GNUC__ && (__GNUC__ > 2 \
- || (__GNUC__ == 2 && __GNUC_MINOR__ >= 5))
-#define NO_RETURN __attribute__ ((__noreturn__))
-#else
-#define NO_RETURN /* nothing */
-#endif
-
#if __GNUC__ >= 3 /* On GCC 3.0 we might get a warning. */
#define NO_INLINE __attribute__((noinline))
#else