summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2012-07-06 14:29:50 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2012-07-06 14:29:50 -0700
commitf5c08e17670cfda756af96c569efa48324b43908 (patch)
tree3bc1549e247c201841b114e6aab640ba402bd64a /configure.in
parentfee5959dd8b389bc222618a35b042a92a1358c21 (diff)
downloademacs-f5c08e17670cfda756af96c569efa48324b43908.tar.gz
* configure.in: Document --enable-gcc-warnings better.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1a43aed7540..09551ae58e9 100644
--- a/configure.in
+++ b/configure.in
@@ -575,7 +575,9 @@ gl_EARLY
AC_ARG_ENABLE([gcc-warnings],
[AS_HELP_STRING([--enable-gcc-warnings],
- [turn on lots of GCC warnings (for developers)])],
+ [turn on lots of GCC warnings. This is intended for
+ developers, and may generate false alarms when used
+ with older or non-GNU development tools.])],
[case $enableval in
yes|no) ;;
*) AC_MSG_ERROR([bad value $enableval for gcc-warnings option]) ;;
@@ -597,7 +599,7 @@ if test "${enableval}" != "no"; then
LTO="-flto=$CPUS"
else
LTO="-flto"
- fi
+ fi
old_CFLAGS=$CFLAGS
CFLAGS="$CFLAGS $LTO"
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[]])],