summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <gerd@gnu.org>2000-05-26 15:56:13 +0000
committerGerd Moellmann <gerd@gnu.org>2000-05-26 15:56:13 +0000
commit25abcaf1c17e151536ca30e1116c363e6ebd1de1 (patch)
treee243a393caf360f3cb023b9f664bebbfe78f54c1 /configure.in
parentf0d21750932435a810749ddfa04f798dfd5636dc (diff)
downloademacs-25abcaf1c17e151536ca30e1116c363e6ebd1de1.tar.gz
Add check for speed_t typedef.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c6bb124f907..577cb4ea5a8 100644
--- a/configure.in
+++ b/configure.in
@@ -1184,6 +1184,14 @@ fi
dnl checks for typedefs
AC_TYPE_SIGNAL
+dnl Check for speed_t typedef.
+AC_CACHE_CHECK(for speed_t, emacs_cv_speed_t,
+AC_TRY_COMPILE([#include <termios.h>], [speed_t x = 1;],
+ emacs_cv_speed_t=yes))
+if test $emacs_cv_speed_t = yes; then
+ AC_DEFINE(HAVE_SPEED_T)
+fi
+
AC_CACHE_CHECK(for struct timeval, emacs_cv_struct_timeval,
AC_TRY_COMPILE([#ifdef TIME_WITH_SYS_TIME
#include <sys/time.h>