summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMiles Bader <miles@gnu.org>2007-04-11 00:17:47 +0000
committerMiles Bader <miles@gnu.org>2007-04-11 00:17:47 +0000
commit57cb2e6f261bb0aad81a9f7e6f3017b54adee068 (patch)
tree6ceb46f2e3bf08f16468d77f4fbfd201f637596a /configure.in
parent3bd1d328e94787ac52ef6ba5dfec3b94ba23917a (diff)
parentc429815a6b9d271a57eed4956125f6bc89d1d72b (diff)
downloademacs-57cb2e6f261bb0aad81a9f7e6f3017b54adee068.tar.gz
Merge from emacs--devo--0
Patches applied: * emacs--devo--0 (patch 675-697) - Update from CVS - Merge from gnus--rel--5.10 - Release ERC 5.2. * gnus--rel--5.10 (patch 211-215) - Update from CVS - Merge from emacs--devo--0 Revision: emacs@sv.gnu.org/emacs--unicode--0--patch-189
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in53
1 files changed, 52 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 572ebd8d51f..b536d8dc105 100644
--- a/configure.in
+++ b/configure.in
@@ -602,6 +602,13 @@ dnl see the `changequote' comment above.
machine=nh6000 opsys=powerunix
NON_GNU_CPP="cc -Xo -E -P"
;;
+ ## SR2001/SR2201 running HI-UX/MPP
+ hppa1.1-hitachi-hiuxmpp* )
+ machine=sr2k opsys=hiuxmpp
+ ;;
+ hppa1.1-hitachi-hiuxwe2* )
+ machine=sr2k opsys=hiuxwe2
+ ;;
## Honeywell XPS100
xps*-honeywell-sysv* )
machine=xps100 opsys=usg5-2
@@ -624,10 +631,46 @@ dnl see the `changequote' comment above.
esac
;;
+ ## HP 9000 series 700 and 800, running HP/UX
+ hppa*-hp-hpux7* )
+ machine=hp800 opsys=hpux
+ ;;
+ hppa*-hp-hpux8* )
+ machine=hp800 opsys=hpux8
+ ;;
+ hppa*-hp-hpux9shr* )
+ machine=hp800 opsys=hpux9shr
+ ;;
+ hppa*-hp-hpux9* )
+ machine=hp800 opsys=hpux9
+ ;;
+ hppa*-hp-hpux10.2* )
+ machine=hp800 opsys=hpux10-20
+ ;;
+ hppa*-hp-hpux10* )
+ machine=hp800 opsys=hpux10
+ ;;
+ hppa*-hp-hpux1[1-9]* )
+ machine=hp800 opsys=hpux11
+ CFLAGS="-D_INCLUDE__STDC_A1_SOURCE $CFLAGS"
+ ;;
+
hppa*-*-linux-gnu* )
machine=hp800 opsys=gnu-linux
;;
+ ## HP 9000 series 700 and 800, running HP/UX
+ hppa*-hp-hpux* )
+ ## Cross-compilation? Nah!
+ case "`uname -r`" in
+ ## Someone's system reports A.B8.05 for this.
+ ## I wonder what other possibilities there are.
+ *.B8.* ) machine=hp800 opsys=hpux8 ;;
+ *.08.* ) machine=hp800 opsys=hpux8 ;;
+ *.09.* ) machine=hp800 opsys=hpux9 ;;
+ *) machine=hp800 opsys=hpux10 ;;
+ esac
+ ;;
hppa*-*-nextstep* )
machine=hp800 opsys=nextstep
;;
@@ -668,6 +711,9 @@ dnl see the `changequote' comment above.
rs6000-ibm-aix4.2* | powerpc-ibm-aix4.2* )
machine=ibmrs6000 opsys=aix4-2
;;
+ rs6000-ibm-aix4.3* | powerpc-ibm-aix4.3* )
+ machine=ibmrs6000 opsys=aix4-2
+ ;;
rs6000-ibm-aix5* | powerpc-ibm-aix5* )
machine=ibmrs6000 opsys=aix4-2
;;
@@ -993,7 +1039,12 @@ dnl see the `changequote' comment above.
;;
*-sunos5* | *-solaris* )
opsys=sol2-6
- NON_GNU_CPP=/usr/ccs/lib/cpp
+ if [ "x$CC" = x/opt/SUNWspro/bin/cc ]; then
+ ## -Xs prevents spurious whitespace.
+ NON_GNU_CPP="/opt/SUNWspro/bin/cc -E -Xs"
+ else
+ NON_GNU_CPP=/usr/ccs/lib/cpp
+ fi
;;
* ) opsys=bsd4-2 ;;
esac