summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJan Djärv <jan.h.d@swipnet.se>2007-06-20 19:38:28 +0000
committerJan Djärv <jan.h.d@swipnet.se>2007-06-20 19:38:28 +0000
commit31ad88509df176b91fd214f526c8c32fe852d624 (patch)
tree042c4d922cc24d0628d0646f1e3e2bb03300fba0 /configure.in
parenteaea8b1da70cd22ea96ca20f5494640df9a6a9a2 (diff)
downloademacs-31ad88509df176b91fd214f526c8c32fe852d624.tar.gz
Complain if X seems to be installed but no
development files where found.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f4d6aa1a5ab..b5c6c1b0aa2 100644
--- a/configure.in
+++ b/configure.in
@@ -1892,6 +1892,22 @@ dnl use the toolkit if we have gtk, or X11R5 or newer.
;;
esac
+if test "$window_system" = none && test "X$with_x" != "Xno"; then
+ AC_CHECK_PROG(HAVE_XSERVER, X, true, false)
+ if test "$HAVE_XSERVER" = true ||
+ test -n "$DISPLAY" ||
+ test "`echo /usr/lib/libX11.*`" != "/usr/lib/libX11.*"; then
+ AC_MSG_ERROR([You seem to be running X, but no X development libraries
+where found. You should install the relevant development files for X
+and the for the toolkit you want, such as Gtk+, Lesstif or Motif. Also make
+sure you have development files for image handling, i.e.
+tiff, gif, jpeg, png and xpm.
+If you are sure you want Emacs compiled without X window support, pass
+ --without-x
+to configure.])
+ fi
+fi
+
### If we're using X11, we should use the X menu package.
HAVE_MENUS=no
case ${HAVE_X11} in