summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2011-06-28 20:21:14 -0700
committerGlenn Morris <rgm@gnu.org>2011-06-28 20:21:14 -0700
commitd34a9bb38f1f3337e7308c36601ddc2d25584ce1 (patch)
tree97f93fcd2a90a6237aa24aa4dc70accb40262fdf /configure.in
parentadbc4ef4b5b969044cdb37cd9a18ed32d766e860 (diff)
downloademacs-d34a9bb38f1f3337e7308c36601ddc2d25584ce1.tar.gz
* configure.in: Tweak previous change.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5374dfe47dd..956167bd4c8 100644
--- a/configure.in
+++ b/configure.in
@@ -1076,7 +1076,6 @@ if test "x$crt_files" != x; then
## system-dependent default from above.]
## Note that this overrides a faulty with-crt-dir.
if test $crt_gcc = yes && test ! -e $CRT_DIR/$file; then
- crt_gcc=no dnl only try once
crt_file=`$CC --print-file-name=$file 2>/dev/null`
case "$crt_file" in
@@ -1086,6 +1085,10 @@ if test "x$crt_files" != x; then
esac
fi
+ dnl We expect all the files to be in a single directory, so after the
+ dnl first there is no point asking gcc.
+ crt_gcc=no
+
test -e $CRT_DIR/$file || crt_missing="$crt_missing $file"
done # $crt_files