summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>1999-10-12 17:13:27 +0000
committerDave Love <fx@gnu.org>1999-10-12 17:13:27 +0000
commit6fa064b6bd95b5f682f0b924c4b7e83840396e13 (patch)
treea834063d4e263a08b4f3e02409d79e4344c20ccd /configure.in
parentebcfda83a0e059e40fe29350fa21690c6026b2cd (diff)
downloademacs-6fa064b6bd95b5f682f0b924c4b7e83840396e13.tar.gz
Default to --with-pop.
Change sense of with-gcc and with-toolkit-scroll-bars messages to reflect the defaults.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 0e10721fe6d..8448e29453e 100644
--- a/configure.in
+++ b/configure.in
@@ -35,10 +35,13 @@ archlibdir='${libexecdir}/emacs/${version}/${configuration}'
docdir='${datadir}/emacs/${version}/etc'
AC_ARG_WITH(gcc,
-[ --with-gcc use GCC to compile Emacs])
+[ --without-gcc don't use GCC to compile Emacs if GCC is found])
AC_ARG_WITH(pop,
-[ --with-pop support POP for mail retrieval],
-[AC_DEFINE(MAIL_USE_POP)])
+[ --without-pop don't support POP mail retrieval with movemail],
+[if test "$withval" = yes; then
+ AC_DEFINE(MAIL_USE_POP)
+else :
+fi])
AC_ARG_WITH(hesiod,
[ --with-hesiod support Hesiod to get the POP server host],
[AC_DEFINE(HESIOD)])
@@ -77,7 +80,7 @@ AC_ARG_WITH(gif,
AC_ARG_WITH(png,
[ --with-png use -lpng for displaying PNG images])
AC_ARG_WITH(toolkit-scroll-bars,
-[ --with-toolkit-scroll-bars use Motif or Xaw3d scroll bars])
+[ --without-toolkit-scroll-bars don't use Motif or Xaw3d scroll bars])
#### Make srcdir absolute, if it isn't already. It's important to
#### avoid running the path through pwd unnecessary, since pwd can