summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <gerd@gnu.org>2000-11-20 14:07:03 +0000
committerGerd Moellmann <gerd@gnu.org>2000-11-20 14:07:03 +0000
commitc776f30b149783b476eb05d296506fd7cee83de5 (patch)
treed4afe34bbd76074c0a679919498e8d33f700dda0 /configure.in
parent2ce63cb7f58e540c18be064c9185f6ca6d5f7890 (diff)
downloademacs-c776f30b149783b476eb05d296506fd7cee83de5.tar.gz
Use -traditional with GNU cpp.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e83b81f1883..341711dc648 100644
--- a/configure.in
+++ b/configure.in
@@ -2257,6 +2257,13 @@ changequote([, ])dnl
echo creating src/epaths.h
make epaths-force
+# As of 2000-11-19, newest development versions of GNU cpp preprocess
+# `..' to `. .' unless invoked with -traditional
+
+if [ x$GCC = xyes && x$NON_GNU_CPP" = x ]; then
+ CPPFLAGS="$CPPFLAGS -traditional"
+fi
+
echo creating lib-src/Makefile
( cd lib-src
rm -f junk.c junk1.c junk2.c