summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKaroly Lorentey <karoly@lorentey.hu>2007-04-22 12:45:07 +0000
committerKaroly Lorentey <karoly@lorentey.hu>2007-04-22 12:45:07 +0000
commit6ca7e0d8570f684ce14f60a6c8fb9545a0c2c935 (patch)
tree45771ca4535584e12b5f4886c65f865b61527213 /configure.in
parent9d0799072a0d09bc14a99eaf372b262d1ba61399 (diff)
parentfcb006c4ee97e3413a794c543367b771f0237495 (diff)
downloademacs-6ca7e0d8570f684ce14f60a6c8fb9545a0c2c935.tar.gz
Merged from emacs@sv.gnu.org
Patches applied: * emacs@sv.gnu.org/emacs--devo--0--patch-702 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-703 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-704 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-705 Update from CVS * emacs@sv.gnu.org/emacs--devo--0--patch-706 Merge from gnus--rel--5.10 * emacs@sv.gnu.org/emacs--devo--0--patch-707 Update from CVS * emacs@sv.gnu.org/gnus--rel--5.10--patch-216 Update from CVS git-archimport-id: lorentey@elte.hu--2004/emacs--multi-tty--0--patch-602
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index edd29d0ad75..19be91bef69 100644
--- a/configure.in
+++ b/configure.in
@@ -1030,6 +1030,8 @@ dnl see the `changequote' comment above.
;;
*-sunos5* | *-solaris* )
opsys=sol2-6
+## FIXME: make this into a proper fix that checks the compiler type,
+## rather than relying on path. Or is /usr/ccs/lib/cpp a bad default now?
if [ "x$CC" = x/opt/SUNWspro/bin/cc ]; then
## -Xs prevents spurious whitespace.
NON_GNU_CPP="/opt/SUNWspro/bin/cc -E -Xs"
@@ -2204,7 +2206,7 @@ fi
dnl Do not put whitespace before the #include statements below.
dnl Older compilers (eg sunos4 cc) choke on it.
-if test x"${USE_X_TOOLKIT}" = xmaybe; then
+if test x"${USE_X_TOOLKIT}" = xmaybe || test x"${USE_X_TOOLKIT}" = xLUCID; then
if test x"${HAVE_X11R5}" = xyes; then
AC_MSG_CHECKING(X11 version 5 with Xaw)
AC_CACHE_VAL(emacs_cv_x11_version_5_with_xaw,
@@ -2218,8 +2220,12 @@ if test x"${USE_X_TOOLKIT}" = xmaybe; then
AC_MSG_RESULT([5 or newer, with Xaw; use toolkit by default])
USE_X_TOOLKIT=LUCID
else
- AC_MSG_RESULT(before 5 or no Xaw; do not use toolkit by default)
- USE_X_TOOLKIT=none
+ if test x"${USE_X_TOOLKIT}" = xLUCID; then
+ AC_MSG_ERROR([Lucid toolkit requires X11/Xaw include files])
+ else
+ AC_MSG_RESULT(before 5 or no Xaw; do not use toolkit by default)
+ USE_X_TOOLKIT=none
+ fi
fi
else
USE_X_TOOLKIT=none