summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJan Djärv <jan.h.d@swipnet.se>2007-06-13 20:43:37 +0000
committerJan Djärv <jan.h.d@swipnet.se>2007-06-13 20:43:37 +0000
commit1ee86f21ec33f04daa3b4dc51d1bead5b95a2947 (patch)
treecf4c9314003153bf03aa4c1805347bae64228d76 /configure.in
parent141f0c038a2cbf9cc91fed54ca6aac76120d216d (diff)
downloademacs-1ee86f21ec33f04daa3b4dc51d1bead5b95a2947.tar.gz
Exit with error if image libraries aren't found.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 65e1e25dc4f..22e15d4a82f 100644
--- a/configure.in
+++ b/configure.in
@@ -2462,6 +2462,9 @@ no_return_alloc_pixels
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
+ AC_MSG_ERROR([libXpm is required, but I didn't find it.
+Maybe some development libraries/packages are missing?
+Use --with-xpm=no if you don't wan't to link with libXpm])
fi
fi
fi
@@ -2479,6 +2482,11 @@ if test "${HAVE_X11}" = "yes"; then
dnl HAVE_STDLIB_H.
AC_CHECK_HEADER(jerror.h,
AC_CHECK_LIB(jpeg, jpeg_destroy_compress, HAVE_JPEG=yes))
+ if test "${HAVE_JPEG}" != "yes"; then
+ AC_MSG_ERROR([libjpeg is required, but I didn't find it.
+Maybe some development libraries/packages are missing?
+Use --with-jpeg=no if you don't wan't to link with libjpeg])
+ fi
fi
AH_TEMPLATE(HAVE_JPEG, [Define to 1 if you have the jpeg library (-ljpeg).])dnl
@@ -2504,6 +2512,11 @@ if test "${HAVE_X11}" = "yes"; then
if test "$ac_cv_header_png_h" = yes || test "$ac_cv_header_libpng_png_h" = yes ; then
AC_CHECK_LIB(png, png_get_channels, HAVE_PNG=yes, , -lz -lm)
fi
+ if test "${HAVE_PNG}" != "yes"; then
+ AC_MSG_ERROR([libpng is required, but I didn't find it.
+Maybe some development libraries/packages are missing?
+Use --with-png=no if you don't wan't to link with libpng])
+ fi
fi
if test "${HAVE_PNG}" = "yes"; then
@@ -2520,6 +2533,11 @@ if test "${HAVE_X11}" = "yes"; then
# At least one tiff package requires the jpeg library.
if test "${HAVE_JPEG}" = yes; then tifflibs="-ljpeg $tifflibs"; fi
AC_CHECK_LIB(tiff, TIFFGetVersion, HAVE_TIFF=yes, , $tifflibs))
+ if test "${HAVE_TIFF}" != "yes"; then
+ AC_MSG_ERROR([libtiff is required, but I didn't find it.
+Maybe some development libraries/packages are missing?
+Use --with-tiff=no if you don't wan't to link with libtiff])
+ fi
fi
if test "${HAVE_TIFF}" = "yes"; then
@@ -2551,6 +2569,10 @@ if test "${HAVE_X11}" = "yes" && test "${with_gif}" != "no"; then
if test "${HAVE_GIF}" = "yes"; then
AC_DEFINE(HAVE_GIF, 1, [Define to 1 if you have a gif library (default -lungif; otherwise specify with LIBGIF).])
+ else
+ AC_MSG_ERROR([libgif or libungif is required, but I didn't find it.
+Maybe some development libraries/packages are missing?
+Use --with-gif=no if you don't wan't to link with libgif/ungif])
fi
fi