summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2007-06-20 07:50:43 +0000
committerGlenn Morris <rgm@gnu.org>2007-06-20 07:50:43 +0000
commit12d9c91d50463a4e8cc5c41df050a674268c0876 (patch)
tree050e87cee17a90d7a1495b6d44a767fd1e28827a /configure.in
parent7adaaf724d9163455cdd167ba4e86a51a33a6cd4 (diff)
downloademacs-12d9c91d50463a4e8cc5c41df050a674268c0876.tar.gz
Prefer libgif over libungif.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 493d5b58eec..f4d6aa1a5ab 100644
--- a/configure.in
+++ b/configure.in
@@ -105,7 +105,7 @@ AC_ARG_WITH(jpeg,
AC_ARG_WITH(tiff,
[ --with-tiff use -ltiff for displaying TIFF images])
AC_ARG_WITH(gif,
-[ --with-gif use -lungif (or -lgif) for displaying GIF images])
+[ --with-gif use -lgif (or -lungif) for displaying GIF images])
AC_ARG_WITH(png,
[ --with-png use -lpng for displaying PNG images])
AC_ARG_WITH(gpm,
@@ -2528,24 +2528,24 @@ if test "${HAVE_X11}" = "yes" && test "${with_gif}" != "no"; then
AC_CHECK_HEADER(gif_lib.h,
# EGifPutExtensionLast only exists from version libungif-4.1.0b1.
# Earlier versions can crash Emacs.
- AC_CHECK_LIB(ungif, EGifPutExtensionLast, HAVE_GIF=yes, try_libgif=yes))
+ AC_CHECK_LIB(gif, EGifPutExtensionLast, HAVE_GIF=yes, try_libungif=yes))
if test "$HAVE_GIF" = yes; then
- ac_gif_lib_name="-lungif"
+ ac_gif_lib_name="-lgif"
fi
-# If gif_lib.h but no libungif, try libgif.
- if test x"$try_libgif" = xyes; then
- AC_CHECK_LIB(gif, EGifPutExtensionLast, HAVE_GIF=yes)
+# If gif_lib.h but no libgif, try libungif.
+ if test x"$try_libungif" = xyes; then
+ AC_CHECK_LIB(ungif, EGifPutExtensionLast, HAVE_GIF=yes)
if test "$HAVE_GIF" = yes; then
- AC_DEFINE(LIBGIF, -lgif, [Compiler option to link with the gif library (if not -lungif).])
- ac_gif_lib_name="-lgif"
+ AC_DEFINE(LIBGIF, -lungif, [Compiler option to link with the gif library (if not -lgif).])
+ ac_gif_lib_name="-lungif"
fi
fi
if test "${HAVE_GIF}" = "yes"; then
- AC_DEFINE(HAVE_GIF, 1, [Define to 1 if you have a gif library (default -lungif; otherwise specify with LIBGIF).])
+ AC_DEFINE(HAVE_GIF, 1, [Define to 1 if you have a gif library (default -lgif; otherwise specify with LIBGIF).])
fi
fi