summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2000-04-14 11:21:41 +0000
committerDave Love <fx@gnu.org>2000-04-14 11:21:41 +0000
commit38c44a9161ee5e5d149743bc5fb6458f65184de0 (patch)
treef98cf4ca2f047338d2fbe8b74209b738cd15e892 /configure.in
parentd3f40cbd579627891b9ca5a6dce0d94a94e69796 (diff)
downloademacs-38c44a9161ee5e5d149743bc5fb6458f65184de0.tar.gz
Use AC_FUNC_GETLOADAVG, AC_FUNC_MKTIME.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 12676dcbf84..86913c5b5aa 100644
--- a/configure.in
+++ b/configure.in
@@ -1843,7 +1843,14 @@ rename closedir mkdir rmdir sysinfo \
random lrand48 bcopy bcmp logb frexp fmod rint cbrt ftime res_init setsid \
strerror fpathconf select mktime euidaccess getpagesize tzset setlocale \
utimes setrlimit setpgid getcwd shutdown strftime getaddrinfo \
-__fpending ftello getloadavg mblen mbrlen strsignal setitimer ualarm)
+__fpending ftello mblen mbrlen strsignal setitimer ualarm)
+
+AC_FUNC_MKTIME
+if test "$ac_cv_func_working_mktime" = no; then
+ AC_DEFINE(BROKEN_MKTIME)
+fi
+
+AC_FUNC_GETLOADAVG
# Check this now, so that we will NOT find the above functions in ncurses.
# That is because we have not set up to link ncurses in lib-src.