summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>2004-03-20 01:08:08 +0000
committerRichard M. Stallman <rms@gnu.org>2004-03-20 01:08:08 +0000
commit0bdea14311dcaaa2069e45bb76ea91a3e8ccd30c (patch)
tree86d030990433609a4966d69d029b414c4738739d /configure.in
parent584c71fadfe40b0165c8d6021f6f6f93ff1998f9 (diff)
downloademacs-0bdea14311dcaaa2069e45bb76ea91a3e8ccd30c.tar.gz
Add -znocombreloc to LDFLAGS if supported.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d5e4ba1e69b..8f80608f4a7 100644
--- a/configure.in
+++ b/configure.in
@@ -1273,6 +1273,18 @@ then
ac_link="$ac_link $NON_GCC_LINK_TEST_OPTIONS"
fi
+dnl We need -znocombreloc if we're using a relatively recent GNU ld.
+dnl If we can link with the flag, it shouldn't do any harm anyhow.
+dnl (Don't use `-z nocombreloc' as -z takes no arg on Irix.)
+late_LDFLAGS=$LDFLAGS
+LDFLAGS="$LDFLAGS -znocombreloc"
+
+AC_MSG_CHECKING([For -znocombreloc])
+AC_LINK_IFELSE([main(){return 0;}],
+ [AC_MSG_RESULT(yes)],
+ LDFLAGS=$late_LDFLAGS
+ [AC_MSG_RESULT(no)])
+
dnl checks for Unix variants
AC_AIX