summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChong Yidong <cyd@stupidchicken.com>2010-05-02 21:42:50 -0400
committerChong Yidong <cyd@stupidchicken.com>2010-05-02 21:42:50 -0400
commitbcb106ad5fd68c5d34994363945267e06f6b7d8d (patch)
treea1be4069508c3404c8c58756e57154748be65e5d /configure.in
parent0a32f71372a872ddf73a4bd3ade1df0a233cdde1 (diff)
downloademacs-bcb106ad5fd68c5d34994363945267e06f6b7d8d.tar.gz
Add check for buggy version of GCC (Bug#6031).
* configure.in: Add check for buggy version of GCC (Bug#6031). * configure: Regenerate * etc/NEWS: Minor tweak to problem description.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2315c267052..9069895508d 100644
--- a/configure.in
+++ b/configure.in
@@ -2600,6 +2600,14 @@ dnl Fixme: Use AC_FUNC_MEMCMP since memcmp is used. (Needs libobj replacement.)
CFLAGS="$REAL_CFLAGS"
CPPFLAGS="$REAL_CPPFLAGS"
+## Hack to detect a buggy GCC version.
+if test "x$GCC" = xyes \
+ && test x"`$CC --version 2> /dev/null | grep 'gcc.* 4.5.0'`" != x \
+ && test x"`echo $CFLAGS | grep '\-O@<:@23@:>@'`" != x \
+ && test x"`echo $CFLAGS | grep '\-fno-optimize-sibling-calls'`" = x; then
+ AC_MSG_ERROR([GCC 4.5.0 has problems compiling Emacs; see etc/PROBLEMS'.])
+fi
+
#### Find out which version of Emacs this is.
[version=`grep 'defconst[ ]*emacs-version' ${srcdir}/lisp/version.el \
| sed -e 's/^[^"]*"\([^"]*\)".*$/\1/'`]