summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChong Yidong <cyd@stupidchicken.com>2011-01-11 21:29:23 -0500
committerChong Yidong <cyd@stupidchicken.com>2011-01-11 21:29:23 -0500
commit5953ae60d44f712e2cadfe9d8ada1816c38f2788 (patch)
tree1e87738bcb770538bd8afb9476ae0c2ea83bfc61 /configure.in
parentec825bb3afdf2e031ec3ee68794fc59c20a1928a (diff)
downloademacs-5953ae60d44f712e2cadfe9d8ada1816c38f2788.tar.gz
Distinguish between terminfo and termcap on NetBSD (Bug#7642).
* configure.in [netbsd systems]: Check for tputs definition. * src/config.in (TERMINFO): New definition. * src/s/netbsd.h: Use it to choose between terminfo and termcap.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2cbd03067db..b15a0bf7a7f 100644
--- a/configure.in
+++ b/configure.in
@@ -2372,6 +2372,15 @@ AC_CHECK_FUNCS(getpt)
# than to expect to find it in ncurses.
AC_CHECK_LIB(ncurses, tparm)
+case "$opsys" in
+ netbsd)
+ AC_SEARCH_LIBS(tputs, [ncurses terminfo termcap])
+ if test $ac_cv_search_tputs = -lterminfo; then
+ AC_DEFINE(TERMINFO, 1, [Define to 1 if you use terminfo instead of termcap.])
+ fi
+ ;;
+esac
+
# Do we have res_init, for detecting changes in /etc/resolv.conf?
resolv=no