summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStefan Monnier <monnier@iro.umontreal.ca>2008-04-16 19:53:06 +0000
committerStefan Monnier <monnier@iro.umontreal.ca>2008-04-16 19:53:06 +0000
commit9184ee0418d4e7ec11f72c832181b05387652118 (patch)
tree68170e5be6d61b303a1dc8367ca740fefc3b8ce5 /configure.in
parentca22de934b6c94bd7cdd3187d724e993f87d9550 (diff)
downloademacs-9184ee0418d4e7ec11f72c832181b05387652118.tar.gz
* configure.in (SYNC_INPUT): Use OPTION_DEFAULT_ON and AC_DEFINE
rather than change CPPFLAGS. (HAVE_GTK): Rename to USE_GTK. * Makefile.in: Don't use HAVE_GTK and don't -DUSE_GTK since it's now done in config.h.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 6 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index c6a0f059c00..31523db9d5c 100644
--- a/configure.in
+++ b/configure.in
@@ -99,6 +99,11 @@ fi
OPTION_DEFAULT_ON([sound],[don't compile with sound support])
+OPTION_DEFAULT_ON([sync-input],[Process async input synchronously])
+if test "$with_sync_input" = yes; then
+ AC_DEFINE(SYNC_INPUT, 1, [Process async input synchronously.])
+fi
+
dnl FIXME currently it is not the last.
dnl This should be the last --with option, because --with-x is
dnl added later on when we find the path of X, and it's best to
@@ -173,12 +178,6 @@ AC_ARG_ENABLE(font-backend,
USE_FONT_BACKEND=$enableval,
USE_FONT_BACKEND=yes)
-## Enabled by default.
-AC_ARG_ENABLE(sync-input,
-[AS_HELP_STRING([--disable-sync-input], [don't compile code with sync-input])],
- USE_SYNC_INPUT=$enableval,
- USE_SYNC_INPUT=yes)
-
AC_ARG_ENABLE(asserts,
[AS_HELP_STRING([--enable-asserts], [compile code with asserts enabled])],
USE_XASSERTS=$enableval,
@@ -1670,7 +1669,7 @@ if test x"$pkg_check_gtk" = xyes; then
fi
else
HAVE_GTK=yes
- AC_DEFINE(HAVE_GTK, 1, [Define to 1 if using GTK.])
+ AC_DEFINE(USE_GTK, 1, [Define to 1 if using GTK.])
USE_X_TOOLKIT=none
if $PKG_CONFIG --atleast-version=2.10 gtk+-2.0; then
:
@@ -3008,11 +3007,6 @@ if test $USE_XASSERTS = yes; then
CPPFLAGS="$CPPFLAGS -DXASSERTS=1"
fi
-if test $USE_SYNC_INPUT = yes; then
- echo " Compiling with sync input."
- CPPFLAGS="$CPPFLAGS -DSYNC_INPUT=1"
-fi
-
echo
if test "$USE_X_TOOLKIT" = GTK; then