summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@linux-m68k.org>2009-07-04 08:12:10 +0000
committerAndreas Schwab <schwab@linux-m68k.org>2009-07-04 08:12:10 +0000
commitdcf8f912731d6612a60f251fba3cfbdc6583709f (patch)
tree9d099f1196d98b5e6e5fc769b4529e8eea57a24e /configure.in
parent3c4d9f8099517fd8515c84ad3e741d10d2bf32e2 (diff)
downloademacs-dcf8f912731d6612a60f251fba3cfbdc6583709f.tar.gz
(--enable-checking, --enable-profiling): Use
AS_HELP_STRING.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 414d9b236bb..b6257a5b067 100644
--- a/configure.in
+++ b/configure.in
@@ -210,12 +210,12 @@ elif test "${enableval}" != "yes"; then
fi)
AC_ARG_ENABLE(checking,
-[ --enable-checking[=LIST]
- enable expensive run-time checks. With LIST,
- enable only specific categories of checks.
- Categories are: all,yes,no.
- Flags are: stringbytes, stringoverrun, stringfreelist,
- xmallocoverrun, conslist],
+[AS_HELP_STRING([--enable-checking@<:@=LIST@:>@],
+ [enable expensive run-time checks. With LIST,
+ enable only specific categories of checks.
+ Categories are: all,yes,no.
+ Flags are: stringbytes, stringoverrun, stringfreelist,
+ xmallocoverrun, conslist])],
[ac_checking_flags="${enableval}"],[])
IFS="${IFS= }"; ac_save_IFS="$IFS"; IFS="$IFS,"
for check in $ac_checking_flags
@@ -274,9 +274,9 @@ if test x$ac_gc_check_cons_list != x ; then
fi
AC_ARG_ENABLE(profiling,
-[ --enable-profiling
- Build emacs with profiling support.
- This might not work on all platforms.],
+[AS_HELP_STRING([--enable-profiling],
+ [build emacs with profiling support.
+ This might not work on all platforms])],
[ac_enable_profiling="${enableval}"],[])
if test x$ac_enable_profiling != x ; then
PROFILING_CFLAGS="-DPROFILING=1 -pg"