summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChong Yidong <cyd@stupidchicken.com>2009-10-23 16:19:37 +0000
committerChong Yidong <cyd@stupidchicken.com>2009-10-23 16:19:37 +0000
commit16abbbf51d9ae4cefd41abdcc0940e94a188a028 (patch)
tree6a7d09e6b3e27e40871eca099ec1f08acbd48817 /configure.in
parentdc13397c4334992aed8f2e1abef05a264ad93697 (diff)
downloademacs-16abbbf51d9ae4cefd41abdcc0940e94a188a028.tar.gz
* configure.in: Invoke $CPP with -P when creating Makefile and
src/Makefile. Without this, gcc 4.4.2 converts each backslash-newline pair in the input to a bare newline, yielding invalid Makefiles. * configure: Regenerate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 87c820ff81c..a1104078089 100644
--- a/configure.in
+++ b/configure.in
@@ -3057,7 +3057,7 @@ echo creating lib-src/Makefile
sed -e '1,/start of cpp stuff/d'\
-e 's,/\*\*/#\(.*\)$,/* \1 */,' \
< Makefile.c > junk.c
- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
cat junk1.c junk2.c > Makefile.new
rm -f junk.c junk1.c junk2.c
@@ -3073,7 +3073,7 @@ echo creating src/Makefile
sed -e '1,/start of cpp stuff/d'\
-e 's,/\*\*/#\(.*\)$,/* \1 */,' \
< Makefile.c > junk.c
- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
cat junk1.c junk2.c > Makefile.new
rm -f junk.c junk1.c junk2.c