summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChong Yidong <cyd@stupidchicken.com>2010-01-12 11:25:08 -0500
committerChong Yidong <cyd@stupidchicken.com>2010-01-12 11:25:08 -0500
commit0635ebd388961e50908530b4af4d63d7ce3e9ef3 (patch)
treeba95846955b8ec98a230d236fd9608fee13d8da8 /configure.in
parent94e1b8f329ef6cfa0824a0510c41db11fbda398e (diff)
downloademacs-0635ebd388961e50908530b4af4d63d7ce3e9ef3.tar.gz
Explicitly check for and link to -lXrender.
See http://lists.gnu.org/archive/html/emacs-devel/2010-01/msg00656.html * configure.in: Explicitly check for and link to -lXrender.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c36c6b2aa3b..39b16c66928 100644
--- a/configure.in
+++ b/configure.in
@@ -1984,12 +1984,17 @@ if test "${HAVE_X11}" = "yes"; then
if test "x${with_xft}" != "xno"; then
PKG_CHECK_MODULES(XFT, xft >= 0.13.0, , HAVE_XFT=no)
- if test "$HAVE_XFT" != no; then
+ ## Because xftfont.c uses XRenderQueryExtension, we also
+ ## need to link to -lXrender.
+ HAVE_XRENDER=no
+ AC_CHECK_LIB(Xrender, XRenderQueryExtension, HAVE_XRENDER=yes)
+ if test "$HAVE_XFT" != no && test "$HAVE_XRENDER" != no; then
OLD_CPPFLAGS="$CPPFLAGS"
OLD_CFLAGS="$CFLAGS"
OLD_LIBS="$LIBS"
CPPFLAGS="$CPPFLAGS $XFT_CFLAGS"
CFLAGS="$CFLAGS $XFT_CFLAGS"
+ XFT_LIBS="-lXrender $XFT_LIBS"
LIBS="$XFT_LIBS $LIBS"
AC_CHECK_HEADER(X11/Xft/Xft.h,
AC_CHECK_LIB(Xft, XftFontOpen, HAVE_XFT=yes, , $XFT_LIBS))