summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2012-11-20 00:29:04 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2012-11-20 00:29:04 -0800
commitd7fcbbfe4a6f310814b45ee1a0aa7ccb458f0eb1 (patch)
treeecdb12cd03c76bced307fc43bd6ff4e0b49c0d3c /configure.ac
parent952580c5fd273ff9d8f095ab8edb6b116d07eb56 (diff)
downloademacs-d7fcbbfe4a6f310814b45ee1a0aa7ccb458f0eb1.tar.gz
Omit -Wstrict-overflow as it does not play well with --enable-checking.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2a079cad264..01fe72d1ee6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -710,6 +710,8 @@ else
nw="$nw -Wfloat-equal" # warns about high-quality code
nw="$nw -Winline" # OK to ignore 'inline'
nw="$nw -Wjump-misses-init" # We sometimes safely jump over init.
+ nw="$nw -Wstrict-overflow" # OK to optimize assuming that
+ # signed overflow has undefined behavior
nw="$nw -Wsync-nand" # irrelevant here, and provokes ObjC warning
nw="$nw -Wunsafe-loop-optimizations" # OK to suppress unsafe optimizations
@@ -720,7 +722,7 @@ else
# The following line should be removable at some point.
nw="$nw -Wsuggest-attribute=pure"
- AC_MSG_CHECKING([whether to use -Wstack-protector -Wstrict-overflow])
+ AC_MSG_CHECKING([whether to use -Wstack-protector])
AC_PREPROC_IFELSE(
[AC_LANG_PROGRAM(
[[#if (1 <= __LONG_MAX__ >> 31 >> 31 \
@@ -732,8 +734,7 @@ else
]])],
[AC_MSG_RESULT(yes)],
[AC_MSG_RESULT(no)
- nw="$nw -Wstack-protector"
- nw="$nw -Wstrict-overflow"])
+ nw="$nw -Wstack-protector"])
gl_MANYWARN_ALL_GCC([ws])
gl_MANYWARN_COMPLEMENT([ws], [$ws], [$nw])