summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDani Moncayo <dmoncayo@gmail.com>2013-12-14 23:59:20 +0100
committerDani Moncayo <dmoncayo@gmail.com>2013-12-14 23:59:20 +0100
commitf629af5493b01170f0fc9c26d8a51c928f4ea711 (patch)
tree0a4a8aaeb9bb030f3237c6ee9e0d64d1d3278756 /configure.ac
parentc07ff981a3fff74bb5a6bf6795eeb1dcead3d074 (diff)
downloademacs-f629af5493b01170f0fc9c26d8a51c928f4ea711.tar.gz
* configure.ac (srcdir) [MINGW32]: Yet another tweak to avoid failure
when srcdir is ".". Fix also the indentation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 6d0ba7c851a..30403fac06d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,16 +26,17 @@ AC_INIT(emacs, 24.3.50)
if test "x$MSYSTEM" = "xMINGW32"
then
- . $srcdir/nt/mingw-cfg.site
-
- if test ${srcdir:0:1} = "/" -o ${srcdir:1:1} = ":"
- then
- # srcdir is an absolute path. In this case, force the format
- # "/c/foo/bar", to simplify later conversions to native Windows
- # format ("c:/foo/bar")
- srcdir=`cd "${srcdir}" && pwd -W`
- srcdir="/${srcdir:0:1}${srcdir:2}"
- fi
+ . $srcdir/nt/mingw-cfg.site
+
+ case $srcdir in
+ /* | ?:*)
+ # srcdir is an absolute path. In this case, force the format
+ # "/c/foo/bar", to simplify later conversions to native Windows
+ # format ("c:/foo/bar")
+ srcdir=`cd "${srcdir}" && pwd -W`
+ srcdir="/${srcdir:0:1}${srcdir:2}"
+ ;;
+ esac
fi
dnl Set emacs_config_options to the options of 'configure', quoted for the shell,