summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2016-10-23 21:54:13 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2016-10-23 21:55:07 -0700
commit7bb5c4f206bfbe46b5f4a376633437f8999d956a (patch)
treea98e0c598786246287995b6b1cf6c7882a253efb /configure.ac
parentee04aedc723b035eedaf975422d4eb242894121b (diff)
downloademacs-7bb5c4f206bfbe46b5f4a376633437f8999d956a.tar.gz
Port --enable-gcc-warnings to bleeding-edge glibc
Bleeding-edge glibc sets emacs_cv_var_doug_lea_malloc to 'no'. Do not merge to master. * configure.ac: Check for valloc decl when compiling gmalloc.c. * src/gmalloc.c (emacs_abort) [emacs]: Adjust decl to match what is in lisp.h. Remove duplicate decl. (aligned_alloc): #undef before defining. (aligned_alloc, memalign) [!MSDOS]: Declare. (valloc) [HAVE_DECL_VALLOC]: Remove duplicate decl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7c115a036db..ae7dfe59029 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2158,7 +2158,10 @@ elif test "$hybrid_malloc" = yes; then
GMALLOC_OBJ=gmalloc.o
VMLIMIT_OBJ=
else
- test "$doug_lea_malloc" != "yes" && GMALLOC_OBJ=gmalloc.o
+ if test "$doug_lea_malloc" != "yes"; then
+ GMALLOC_OBJ=gmalloc.o
+ AC_CHECK_DECLS([valloc])
+ fi
VMLIMIT_OBJ=vm-limit.o
AC_CHECK_HEADERS([sys/vlimit.h])