summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2012-08-20 12:17:36 -0600
committerTom Tromey <tromey@redhat.com>2012-08-20 12:17:36 -0600
commit68608de20310c42c5719fe99e556847fac9dd1f2 (patch)
treeb656eb2541a476f8f5afdbb710c61347e37bf864 /configure.ac
parentfb77afbe75308507885113a56017f095da8ba1cc (diff)
downloademacs-68608de20310c42c5719fe99e556847fac9dd1f2.tar.gz
pass the thread name to the OS if possible
use prctl to pass the thread name to the OS, if possible
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2394790c455..90c0ef07aa1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1230,7 +1230,7 @@ AC_CHECK_HEADERS_ONCE(
linux/version.h sys/systeminfo.h
stdio_ext.h fcntl.h coff.h pty.h
sys/vlimit.h sys/resource.h
- sys/utsname.h pwd.h utmp.h dirent.h util.h)
+ sys/utsname.h pwd.h utmp.h dirent.h util.h sys/prctl.h)
AC_MSG_CHECKING(if personality LINUX32 can be set)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/personality.h>]], [[personality (PER_LINUX32)]])],
@@ -2731,7 +2731,7 @@ gai_strerror mkstemp getline getdelim fsync sync \
difftime posix_memalign \
getpwent endpwent getgrent endgrent \
touchlock \
-cfmakeraw cfsetspeed copysign __executable_start)
+cfmakeraw cfsetspeed copysign __executable_start prctl)
dnl getwd appears to be buggy on SVR4.2, so we don't use it.
if test $opsys = unixware; then