summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen Brown <kbrown@cornell.edu>2014-09-27 19:35:50 -0400
committerKen Brown <kbrown@cornell.edu>2014-09-27 19:35:50 -0400
commitbbf5e14b387ee69a360cccefbf77c0bca792aab7 (patch)
tree539fb56c5f74d6ccf3140ea82455e2998afbdd9f /configure.ac
parent6c300919bc93033a6cad137e94bf6b1653428256 (diff)
downloademacs-bbf5e14b387ee69a360cccefbf77c0bca792aab7.tar.gz
* configure.ac [CYGWIN]: Enable sound support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4d9cc0d0274..5fd49280dd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -254,7 +254,7 @@ AC_ARG_WITH([mailhost],[AS_HELP_STRING([--with-mailhost=HOSTNAME],
AC_ARG_WITH([sound],[AS_HELP_STRING([--with-sound=VALUE],
[compile with sound support (VALUE one of: yes, alsa, oss, bsd-ossaudio, no;
-default yes). Only for GNU/Linux, FreeBSD, NetBSD, MinGW.])],
+default yes). Only for GNU/Linux, FreeBSD, NetBSD, MinGW, Cygwin.])],
[ case "${withval}" in
yes|no|alsa|oss|bsd-ossaudio) val=$withval ;;
*) AC_MSG_ERROR([`--with-sound=$withval' is invalid;
@@ -1442,7 +1442,7 @@ AC_DEFUN([EMACS_CHECK_MODULES],
HAVE_SOUND=no
if test "${with_sound}" != "no"; then
- # Sound support for GNU/Linux, the free BSDs, and MinGW.
+ # Sound support for GNU/Linux, the free BSDs, MinGW, and Cygwin.
AC_CHECK_HEADERS([machine/soundcard.h sys/soundcard.h soundcard.h mmsystem.h],
have_sound_header=yes, [], [
#ifdef __MINGW32__
@@ -1505,7 +1505,7 @@ if test "${with_sound}" != "no"; then
case "$opsys" in
dnl defined __FreeBSD__ || defined __NetBSD__ || defined __linux__
dnl Adjust the --with-sound help text if you change this.
- gnu-linux|freebsd|netbsd|mingw32)
+ gnu-linux|freebsd|netbsd|mingw32|cygwin)
AC_DEFINE(HAVE_SOUND, 1, [Define to 1 if you have sound support.])
HAVE_SOUND=yes
;;