summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2012-09-26 18:06:23 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2012-09-26 18:06:23 -0700
commita615a3aeef0fb1469dcf89e2217a027a6dce82c1 (patch)
tree6a9d26ac4b2a5ac287af1485234637c992474e12 /configure.ac
parent3670daf7f9a480d8e87b292ff7051d5be331c6b4 (diff)
downloademacs-a615a3aeef0fb1469dcf89e2217a027a6dce82c1.tar.gz
Check more robustly for timer_settime.
This should fix an OS X build problem reported by Ivan Andrus in <http://lists.gnu.org/archive/html/emacs-devel/2012-09/msg00671.html>. * admin/merge-gnulib (GNULIB_MODULES): Add timer-time. * configure.ac (gl_THREADLIB): Define to empty, since Emacs does threads its own way. * lib/gnulib.mk, m4/gnulib-comp.m4: Regenerate. * m4/timer_time.m4: New file, from gnulib. * src/atimer.c (alarm_timer, alarm_timer_ok, set_alarm, init_atimer): Use HAVE_TIMER_SETTIME, not SIGEV_SIGNAL, to decide whether to call timer_settime.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a6462f7959a..5a3aea763c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -571,6 +571,9 @@ else
test "x$NON_GCC_TEST_OPTIONS" != x && CC="$CC $NON_GCC_TEST_OPTIONS"
fi
+# Avoid gnulib's threadlib module, as we do threads our own way.
+AC_DEFUN([gl_THREADLIB])
+
# Initialize gnulib right after choosing the compiler.
gl_EARLY