summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2012-11-20 20:47:55 -0800
committerGlenn Morris <rgm@gnu.org>2012-11-20 20:47:55 -0800
commit6ef2e5ef5278a807132b78c42de402925b20bfb3 (patch)
treee5711cdfcdf8a152416c2a96e399695285a4a3a8 /configure.ac
parenteadf1faa3cb5eea8c25a5166a9a97ebd63525c56 (diff)
parentb6729a180f4b81ac26bd7b61f5330643b2d5e994 (diff)
downloademacs-6ef2e5ef5278a807132b78c42de402925b20bfb3.tar.gz
Merge from emacs-24; up to 2012-11-17T22:12:47Z!eggert@cs.ucla.edu
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 01fe72d1ee6..343a9e7cfb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -329,10 +329,15 @@ if test "${enableval}" != "no"; then
fi)
+dnl The name of this option is unfortunate. It predates, and has no
+dnl relation to, the "sampling-based elisp profiler" added in 24.3.
+dnl Actually, it stops it working.
+dnl http://lists.gnu.org/archive/html/emacs-devel/2012-11/msg00393.html
AC_ARG_ENABLE(profiling,
[AS_HELP_STRING([--enable-profiling],
- [build emacs with profiling support.
- This might not work on all platforms])],
+ [build emacs with low-level, gprof profiling support.
+ Mainly useful for debugging Emacs itself. May not work on
+ all platforms. Stops profiler.el working.])],
[ac_enable_profiling="${enableval}"],[])
if test x$ac_enable_profiling != x ; then
PROFILING_CFLAGS="-DPROFILING=1 -pg"