summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-02-08 21:00:49 +0100
committerUlrich Müller <ulm@gentoo.org>2015-02-08 21:09:22 +0100
commitdbde138155118344b33dfd2db95f688a24a42fec (patch)
tree0a23eda7c98b68988683576a6fd6a32954b564f4 /configure.ac
parent19ee7875db8b154a3ba49a98da2d3c24b03fff1e (diff)
downloademacs-dbde138155118344b33dfd2db95f688a24a42fec.tar.gz
configure --with-gameuser now defaults to games group.
* configure.ac (--with-gameuser): Default to 'games' group instead of 'games' user. * lisp/play/gamegrid.el: Update comment to reflect that the 'update-game-score' helper program is now setgid by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 5776e4ef8ed..192634bdc45 100644
--- a/configure.ac
+++ b/configure.ac
@@ -397,17 +397,12 @@ AC_ARG_WITH(gameuser,dnl
An argument prefixed by ':' specifies a group instead.])])
gameuser=
gamegroup=
+# We don't test if we can actually chown/chgrp here, because configure
+# may run without root privileges. lib-src/Makefile.in will handle
+# any errors due to missing user/group gracefully.
case ${with_gameuser} in
no) ;;
- "" | yes)
- AC_MSG_CHECKING([whether a 'games' user exists])
- if id -u games >/dev/null 2>&1; then
- AC_MSG_RESULT([yes])
- gameuser=games
- else
- AC_MSG_RESULT([no])
- fi
- ;;
+ "" | yes) gamegroup=games ;;
:*) gamegroup=`echo "${with_gameuser}" | sed -e "s/://"` ;;
*) gameuser=${with_gameuser} ;;
esac