summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-05-23 21:18:35 +0200
committerPhilipp Stephani <phst@google.com>2017-05-23 21:18:35 +0200
commitcd9c7a0617b58169b5788ff30de97afdbac5e882 (patch)
tree98c42c0a0d4dbfb11b37ff0f85add7dd3b662708 /configure.ac
parent63d0a3c63f833faad7a04fb4bf384d55ae6ae8d1 (diff)
downloademacs-cd9c7a0617b58169b5788ff30de97afdbac5e882.tar.gz
Don't warn about missing brances on macOS
On macOS, removing -Wmissing-braces is not enough; the warning has to be disabled explicitly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 12e44d949c5..6d23b5d214e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -986,6 +986,7 @@ AS_IF([test $gl_gcc_warnings = no],
# More things that clang is unduly picky about.
if test $emacs_cv_clang = yes; then
+ gl_WARN_ADD([-Wno-missing-braces])
gl_WARN_ADD([-Wno-tautological-compare])
gl_WARN_ADD([-Wno-tautological-constant-out-of-range-compare])
fi