summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2013-08-26 08:46:30 -0600
committerTom Tromey <tromey@redhat.com>2013-08-26 08:46:30 -0600
commit2ee7755c8d35aba1d598c9baa910bd5af228f095 (patch)
tree0eb4817057fef64fb07767f8b025b4d47fb80cb6 /configure.ac
parent793ea5055aea85ff9227e1bf0c84ab37edba7201 (diff)
downloademacs-2ee7755c8d35aba1d598c9baa910bd5af228f095.tar.gz
implement --enable-threads and a thread-less mode
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bbd799cadee..6b22cd0cfab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -237,6 +237,7 @@ OPTION_DEFAULT_ON([gsettings],[don't compile with GSettings support])
OPTION_DEFAULT_ON([selinux],[don't compile with SELinux support])
OPTION_DEFAULT_ON([gnutls],[don't use -lgnutls for SSL/TLS support])
OPTION_DEFAULT_ON([zlib],[don't compile with zlib decompression support])
+OPTION_DEFAULT_ON([threads],[don't compile with elisp threading support])
AC_ARG_WITH([file-notification],[AS_HELP_STRING([--with-file-notification=LIB],
[use a file notification library (LIB one of: yes, gfile, inotify, w32, no)])],
@@ -1948,6 +1949,17 @@ AC_SUBST([LIB_PTHREAD])
AC_CHECK_LIB(pthreads, cma_open)
+AC_MSG_CHECKING([for thread support])
+threads_enabled=no
+if test "$with_threads" = yes; then
+ if test "$HAVE_PTHREAD" = yes; then
+ AC_DEFINE(THREADS_ENABLED, 1,
+ [Define to 1 if you want elisp thread support.])
+ threads_enabled=yes
+ fi
+fi
+AC_MSG_RESULT([$threads_enabled])
+
## Note: when using cpp in s/aix4.2.h, this definition depended on
## HAVE_LIBPTHREADS. That was not defined earlier in configure when
## the system file was sourced. Hence the value of LIBS_SYSTEM
@@ -4843,6 +4855,7 @@ echo " Does Emacs use -lxft? ${HAVE_XFT}"
echo " Does Emacs directly use zlib? ${HAVE_ZLIB}"
echo " Does Emacs use toolkit scroll bars? ${USE_TOOLKIT_SCROLL_BARS}"
+echo " Does Emacs have threading support in elisp? ${threads_enabled}"
echo
if test -n "${EMACSDATA}"; then