summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2018-08-14 16:06:05 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2018-08-14 16:06:59 -0700
commit1164d49ba6a3ce59a2bd404219851d8e27b54611 (patch)
treea65103b074084b4723b30b6ad20a44b90e96646c /configure.ac
parent6d24402d6358b2e6ccf78a6cb909723a5d18dd27 (diff)
downloademacs-1164d49ba6a3ce59a2bd404219851d8e27b54611.tar.gz
Rename --without-mini-gmp to --with-libgmp
* configure.ac (HAVE_GMP): Rename ‘configure’ option from --without-mini-gmp to --with-libgmp. All uses changed. * doc/lispref/numbers.texi (Predicates on Numbers): Large integers are always available. Clarify how eq works on them.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 7 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 7b9448e13b0..e5d094cf9ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4303,17 +4303,16 @@ AC_SUBST(KRB5LIB)
AC_SUBST(DESLIB)
AC_SUBST(KRB4LIB)
-AC_ARG_WITH([mini-gmp],
- [AS_HELP_STRING([--without-mini-gmp],
- [don't compile and use mini-gmp, a substitute for the
- GNU Multiple Precision (GMP) library; this is the
- default on systems with recent-enough GMP.])])
+AC_ARG_WITH([libgmp],
+ [AS_HELP_STRING([--without-libgmp],
+ [don't use the GNU Multiple Precision (GMP) library;
+ this is the default on systems lacking libgmp.])])
GMP_LIB=
GMP_OBJ=mini-gmp-emacs.o
HAVE_GMP=no
-case $with_mini_gmp in
- yes) ;;
- no) HAVE_GMP=yes GMP_LIB=-lgmp;;
+case $with_libgmp in
+ no) ;;
+ yes) HAVE_GMP=yes GMP_LIB=-lgmp;;
*) AC_CHECK_HEADERS([gmp.h],
[OLIBS=$LIBS
AC_SEARCH_LIBS([__gmpz_roinit_n], [gmp])