summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen Brown <kbrown@cornell.edu>2019-02-22 09:53:52 -0500
committerKen Brown <kbrown@cornell.edu>2019-02-22 10:12:33 -0500
commit6d46fa961c93d435e70b046ef2c400b81934ace8 (patch)
tree2b8fa8272c90031a2d04ac51432bf37b9a5360db /configure.ac
parent3707ea434f1801f911e51896b987be61b4e4c7c2 (diff)
downloademacs-6d46fa961c93d435e70b046ef2c400b81934ace8.tar.gz
Disable the timerfd interface on Cygwin
* configure.ac (emacs_cv_have_timerfd): Set to "no" on Cygwin.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d5e802a961f..097c3bc68af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4145,6 +4145,10 @@ AC_SUBST(LIBS_TERMCAP)
AC_SUBST(TERMCAP_OBJ)
# GNU/Linux-specific timer functions.
+# Bug#34618.
+if test "$opsys" = "cygwin"; then
+ emacs_cv_have_timerfd=no
+fi
AC_CACHE_CHECK([for timerfd interface], [emacs_cv_have_timerfd],
[AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM([[#include <sys/timerfd.h>