summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen Raeburn <raeburn@raeburn.org>2016-03-08 22:17:16 -0500
committerKen Raeburn <raeburn@raeburn.org>2016-03-10 14:28:54 -0500
commit8b8a6ad3e3239eb2cff325e72e29dc30fdaa58c5 (patch)
treefab743803408a7c0fcf1f1416a187f863505b2d1 /configure.ac
parent985dacfa0f0186531fdae13718d720cf7e27425f (diff)
downloademacs-8b8a6ad3e3239eb2cff325e72e29dc30fdaa58c5.tar.gz
Don't use XRANDR 1.3 extensions if the server doesn't support them.
* src/xterm.h (struct x_display_info): Add fields to save XRANDR version number. * src/xfns.c (x_get_monitor_attributes): Save the version numbers after querying the X server. (x_get_monitor_attributes_xrandr): Don't use XRRGetOutputPrimary or XRRGetScreenResourcesCurrent if the server doesn't support at least RANDR version 1.3. Conditionalize the code blocks on compiling against library version 1.3 or better, rather than feature tests for each function. * configure.ac: Stop testing for those two functions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 370cb54fe2c..075f6119ead 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3594,14 +3594,6 @@ if test "${HAVE_X11}" = "yes"; then
fi
fi
if test $HAVE_XRANDR = yes; then
- SAVE_CFLAGS="$CFLAGS"
- SAVE_LIBS="$LIBS"
- CFLAGS="$XRANDR_CFLAGS $CFLAGS"
- LIBS="$XRANDR_LIBS $LIBS"
- AC_CHECK_FUNCS(XRRGetOutputPrimary XRRGetScreenResourcesCurrent)
- CFLAGS="$SAVE_CFLAGS"
- LIBS="$SAVE_LIBS"
-
AC_DEFINE(HAVE_XRANDR, 1, [Define to 1 if you have the XRandr extension.])
fi
fi