summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2016-01-17 14:10:26 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2016-01-17 14:11:09 -0800
commitfabb1fa31d1fd60764c025925e6c76c9145e5a59 (patch)
tree9bb5e66cb3fac71c258e37954210e2be056a44b2 /configure.ac
parent05e8148a24ebe51fbe758dd16265e8fb81f85953 (diff)
downloademacs-fabb1fa31d1fd60764c025925e6c76c9145e5a59.tar.gz
Port cleanup attribute to OpenBSD
The OpenBSD C compiler issues false alarms about strcpy, strcat, and sprintf, and this messes up 'configure' when it tests for the cleanup attribute. Work around the problem by using __has_attribute directly. Problem reported by Joakim Jalap (Bug#22385). * configure.ac: Don’t use AX_GCC_VAR_ATTRIBUTE. * m4/ax_gcc_var_attribute.m4: Remove. * src/conf_post.h (__has_attribute): Provide a substitute, for non-GCC or older GCC compilers. All uses changed to assume the substitute. Check for the cleanup attribute. * src/emacs-module.c (module_has_cleanup): Just use __has_attribute.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8c01abac9c6..3aeba22ec47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3327,7 +3327,6 @@ if test "${HAVE_MODULES}" = yes; then
fi
AC_SUBST(MODULES_OBJ)
AC_SUBST(LIBMODULES)
-AX_GCC_VAR_ATTRIBUTE(cleanup)
AC_CHECK_FUNCS(dladdr)
### Use -lpng if available, unless '--with-png=no'.