summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2013-10-27 11:57:20 -0700
committerGlenn Morris <rgm@gnu.org>2013-10-27 11:57:20 -0700
commita94fc965f4d32cae0e9b93b8c8947612a540d1b9 (patch)
tree1cd681b94f0cb8894e65801c6c70f07515d76379 /configure.ac
parent73d40d1e6427db02b0c5ab0500b92eda0cd7db8b (diff)
downloademacs-a94fc965f4d32cae0e9b93b8c8947612a540d1b9.tar.gz
* configure.ac: It seems installing in non-ASCII is not, in fact, ok.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2c1123f3a0b..9263d395244 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,11 @@ dnl --program-transform-name options
AC_ARG_PROGRAM
dnl http://debbugs.gnu.org/15260
+dnl I think we have to check, eg, both exec_prefix and bindir,
+dnl because the latter by default is not yet expanded, but the user
+dnl may have specified a value for it via --bindir.
+dnl At first glance, _installing_ in non-ASCII seems ok, but in fact
+dnl it is not; see http://debbugs.gnu.org/15260#61
dnl Note that abs_srcdir and abs_builddir are not yet defined. :(
dnl "`cd \"$srcdir\"`" is not portable.
@@ -82,11 +87,12 @@ dnl "There is just no portable way to use double-quoted strings inside
dnl double-quoted back-quoted expressions (pfew!)."
temp_srcdir=`cd "$srcdir"; pwd`
-for var in "`pwd`" "$temp_srcdir"; do
+for var in "`pwd`" "$temp_srcdir" "$prefix" "$exec_prefix" \
+ "$datarootdir" "$bindir" "$datadir" "$sharedstatedir" "$libexecdir"; do
dnl configure sets LC_ALL=C early on, so this range should work.
case "$var" in
- *[[^\ -~]]*) AC_MSG_ERROR([Emacs cannot be built in a directory whose name contains non-ASCII characters: $var]) ;;
+ *[[^\ -~]]*) AC_MSG_ERROR([Emacs cannot be built or installed in a directory whose name contains non-ASCII characters: $var]) ;;
esac
done