summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2018-08-27 21:44:29 -0400
committerGlenn Morris <rgm@gnu.org>2018-08-27 21:44:29 -0400
commit2695b7e74559318cee2b4e69c2f94ac22421d134 (patch)
tree5cb1fc480a9aa6249547e07d54efbccdc52d9be6 /configure.ac
parentd0d162c2d63600435622ad4cb5e67e98d1a36da4 (diff)
downloademacs-2695b7e74559318cee2b4e69c2f94ac22421d134.tar.gz
* configure.ac: Doc fixes related to --with-xim.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3d39cd0c3ba..868930bb5ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -362,7 +362,7 @@ OPTION_DEFAULT_ON([m17n-flt],[don't use m17n-flt for text shaping])
OPTION_DEFAULT_ON([toolkit-scroll-bars],[don't use Motif or Xaw3d scroll bars])
OPTION_DEFAULT_ON([xaw3d],[don't use Xaw3d])
-OPTION_DEFAULT_ON([xim],[don't use X11 XIM])
+OPTION_DEFAULT_ON([xim],[at runtime, default X11 XIM to off])
AC_ARG_WITH([ns],[AS_HELP_STRING([--with-ns],
[use Nextstep (macOS Cocoa or GNUstep) windowing system.
On by default on macOS.])],[],[with_ns=maybe])
@@ -3149,11 +3149,12 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
AC_DEFINE(HAVE_XIM, 1, [Define to 1 if XIM is available])],
HAVE_XIM=no)
-dnl '--with-xim' now controls only the initial value of use_xim at run time.
-
+dnl Note this is non-standard. --with-xim does not control whether
+dnl XIM support is compiled in, it only affects the runtime default of
+dnl use_xim in xterm.c.
if test "${with_xim}" != "no"; then
AC_DEFINE(USE_XIM, 1,
- [Define to 1 if we should use XIM, if it is available.])
+ [Define to 1 to default runtime use of XIM to on.])
fi