summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen Brown <kbrown@cornell.edu>2014-04-03 15:10:35 -0400
committerKen Brown <kbrown@cornell.edu>2014-04-03 15:10:35 -0400
commitebe8e0765cf469daeda515bab7e3afa6a35fcb43 (patch)
tree6677e7b18ab6433ecf82df66874c15833b8509a8 /configure.ac
parentb54b4b12d498ba451dcbde2de0fffbc2c9afc613 (diff)
downloademacs-ebe8e0765cf469daeda515bab7e3afa6a35fcb43.tar.gz
Don't use manifest on Cygwin. (Bug#17176)
* nt/emacs.rc: Don't use manifest on Cygwin. * configure.ac (EMACS_MANIFEST, UPDATE_MANIFEST): Leave these variables empty on Cygwin. * src/Makefile.in (EMACS_MANIFEST): Update comment.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 83bbb32959b..086bd7d4bdf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1834,11 +1834,6 @@ if test "${HAVE_W32}" = "yes"; then
W32_OBJ="w32fns.o w32menu.o w32reg.o w32font.o w32term.o"
W32_OBJ="$W32_OBJ w32xfns.o w32select.o w32uniscribe.o"
EMACSRES="emacs.res"
- case "$canonical" in
- x86_64-*-*) EMACS_MANIFEST="emacs-x64.manifest" ;;
- *) EMACS_MANIFEST="emacs-x86.manifest" ;;
- esac
- UPDATE_MANIFEST=update-game-score.exe.manifest
if test "${opsys}" = "cygwin"; then
W32_LIBS="$W32_LIBS -lkernel32 -luser32 -lgdi32 -lole32 -lcomdlg32"
W32_LIBS="$W32_LIBS -lusp10 -lcomctl32 -lwinspool"
@@ -1846,6 +1841,11 @@ if test "${HAVE_W32}" = "yes"; then
# the rc file), not a linker script.
W32_RES_LINK="-Wl,emacs.res"
else
+ case "$canonical" in
+ x86_64-*-*) EMACS_MANIFEST="emacs-x64.manifest" ;;
+ *) EMACS_MANIFEST="emacs-x86.manifest" ;;
+ esac
+ UPDATE_MANIFEST=update-game-score.exe.manifest
W32_OBJ="$W32_OBJ w32.o w32console.o w32heap.o w32inevt.o w32proc.o"
W32_LIBS="$W32_LIBS -lwinmm -lgdi32 -lcomdlg32"
W32_LIBS="$W32_LIBS -lmpr -lwinspool -lole32 -lcomctl32 -lusp10"