summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2013-10-24 19:22:13 -0700
committerGlenn Morris <rgm@gnu.org>2013-10-24 19:22:13 -0700
commitda504eec7088eeb698f3987900ed7757363602c3 (patch)
tree37ef3ae0ce35a05505f862488163e97bf7ab105c /configure.ac
parent37241f62069b8f60e28d419ca502dd04ba567ab9 (diff)
downloademacs-da504eec7088eeb698f3987900ed7757363602c3.tar.gz
* configure.ac: It seems _installing_ in non-ASCII is ok, not building.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 7d8cb8815fd..2c1123f3a0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,23 +74,19 @@ dnl --program-transform-name options
AC_ARG_PROGRAM
dnl http://debbugs.gnu.org/15260
-dnl I think we have to check, eg, both exec_prefix and bindir,
-dnl because the latter by default is not yet expanded, but the user
-dnl may have specified a value for it via --bindir.
dnl Note that abs_srcdir and abs_builddir are not yet defined. :(
-dnl "`cd \"$srcdir\" is not portable.
+dnl "`cd \"$srcdir\"`" is not portable.
dnl See autoconf manual "Shell Substitutions":
dnl "There is just no portable way to use double-quoted strings inside
dnl double-quoted back-quoted expressions (pfew!)."
temp_srcdir=`cd "$srcdir"; pwd`
-for var in "`pwd`" "$temp_srcdir" "$prefix" "$exec_prefix" \
- "$datarootdir" "$bindir" "$datadir" "$sharedstatedir" "$libexecdir"; do
+for var in "`pwd`" "$temp_srcdir"; do
dnl configure sets LC_ALL=C early on, so this range should work.
case "$var" in
- *[[^\ -~]]*) AC_MSG_ERROR([Emacs cannot be built or installed in a directory whose name contains non-ASCII characters: $var]) ;;
+ *[[^\ -~]]*) AC_MSG_ERROR([Emacs cannot be built in a directory whose name contains non-ASCII characters: $var]) ;;
esac
done