summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2013-10-23 16:46:46 -0400
committerGlenn Morris <rgm@gnu.org>2013-10-23 16:46:46 -0400
commit7b65c8d0b93e2d1b06dec9d756a02d2034c7865a (patch)
tree35f469ca72c7d15fbff9bcd9d90ebe4ea2792fe7 /configure.ac
parentd5f1282f05c6ea7ad7abb9c27d784e09faa45e4a (diff)
downloademacs-7b65c8d0b93e2d1b06dec9d756a02d2034c7865a.tar.gz
* configure.ac: Explicit error for non-ASCII directories
Fixes: debbugs:15260
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d88f1d39b66..74ac7695cdc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,6 +73,17 @@ dnl Support for --program-prefix, --program-suffix and
dnl --program-transform-name options
AC_ARG_PROGRAM
+dnl http://debbugs.gnu.org/15260
+for var in "`pwd`" "`cd \"$srcdir\"; pwd`" "$bindir" \
+ "$datadir" "$sharedstatedir" "$libexecdir"; do
+
+ dnl configure sets LC_ALL=C early on, so this range should work.
+ case "$var" in
+ *[[^\ -~]]*) AC_MSG_ERROR([Emacs cannot be built or installed in a directory whose name contains non-ASCII characters: $var]) ;;
+ esac
+
+done
+
dnl It is important that variables on the RHS not be expanded here,
dnl hence the single quotes. This is per the GNU coding standards, see
dnl (autoconf) Installation Directory Variables