summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2017-09-19 20:31:02 +0300
committerEli Zaretskii <eliz@gnu.org>2017-09-19 20:31:02 +0300
commit7b3d1c6beb54ef6c423a93df88aebfd6fecbe2c2 (patch)
treeebd80cb577de50e9b99233c623fc99733f9e3c20 /configure.ac
parentc83d0c5fdfd374d5c2e1547d05f02ab3b47a4a5a (diff)
downloademacs-7b3d1c6beb54ef6c423a93df88aebfd6fecbe2c2.tar.gz
Fix MinGW64 build broken by recent MinGW64 import libraries
* configure.ac (W32_LIBS): Put -lusp10 before -lgdi32, as latest MinGW64 import libraries require that. (Bug#28493) * src/Makefile.in: Adjust commentary to the new order of w32 libraries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6452038d1b9..0b0bb5e144b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2077,15 +2077,15 @@ if test "${HAVE_W32}" = "yes"; then
AC_SUBST(comma_space_version)
AC_CONFIG_FILES([nt/emacs.rc nt/emacsclient.rc])
if test "${opsys}" = "cygwin"; then
- W32_LIBS="$W32_LIBS -lkernel32 -luser32 -lgdi32 -lole32 -lcomdlg32"
- W32_LIBS="$W32_LIBS -lusp10 -lcomctl32 -lwinspool"
+ W32_LIBS="$W32_LIBS -lkernel32 -luser32 -lusp10 -lgdi32"
+ W32_LIBS="$W32_LIBS -lole32 -lcomdlg32 -lcomctl32 -lwinspool"
# Tell the linker that emacs.res is an object (which we compile from
# the rc file), not a linker script.
W32_RES_LINK="-Wl,emacs.res"
else
W32_OBJ="$W32_OBJ w32.o w32console.o w32heap.o w32inevt.o w32proc.o"
- W32_LIBS="$W32_LIBS -lwinmm -lgdi32 -lcomdlg32"
- W32_LIBS="$W32_LIBS -lmpr -lwinspool -lole32 -lcomctl32 -lusp10"
+ W32_LIBS="$W32_LIBS -lwinmm -lusp10 -lgdi32 -lcomdlg32"
+ W32_LIBS="$W32_LIBS -lmpr -lwinspool -lole32 -lcomctl32"
W32_RES_LINK="\$(EMACSRES)"
CLIENTRES="emacsclient.res"
CLIENTW="emacsclientw\$(EXEEXT)"