summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-10-01 19:53:56 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-10-01 19:59:01 -0700
commit5172fa02cccaab2500ecf85aaf65b8deed54d42e (patch)
tree6e3c39413eb2f1c039ba48626ccf7bc0df24c9f6 /configure.ac
parent8cdd8b920a80e4c61270b0a90f51fb4c8db85c6e (diff)
downloademacs-5172fa02cccaab2500ecf85aaf65b8deed54d42e.tar.gz
Prefer HTTPS to HTTP for gnu.org
This fixes some URLs I omitted from my previous pass, notably those in lists.gnu.org. Although lists.gnu.org does not yet support TLS 1.1, TLS 1.0 is better than nothing. * lisp/erc/erc.el (erc-official-location): * lisp/mail/emacsbug.el (report-emacs-bug): Use https:, not http:.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0b0bb5e144b..eb2c6840402 100644
--- a/configure.ac
+++ b/configure.ac
@@ -396,7 +396,7 @@ OPTION_DEFAULT_OFF([xwidgets],
## For the times when you want to build Emacs but don't have
## a suitable makeinfo, and can live without the manuals.
-dnl http://lists.gnu.org/archive/html/emacs-devel/2008-04/msg01844.html
+dnl https://lists.gnu.org/archive/html/emacs-devel/2008-04/msg01844.html
OPTION_DEFAULT_ON([makeinfo],[don't require makeinfo for building manuals])
## Makefile.in needs the cache file name.
@@ -522,7 +522,7 @@ fi
dnl The name of this option is unfortunate. It predates, and has no
dnl relation to, the "sampling-based elisp profiler" added in 24.3.
dnl Actually, it stops it working.
-dnl http://lists.gnu.org/archive/html/emacs-devel/2012-11/msg00393.html
+dnl https://lists.gnu.org/archive/html/emacs-devel/2012-11/msg00393.html
AC_ARG_ENABLE(profiling,
[AS_HELP_STRING([--enable-profiling],
[build emacs with low-level, gprof profiling support.
@@ -948,7 +948,7 @@ AS_IF([test $gl_gcc_warnings = no],
nw="$nw -Wbad-function-cast" # These casts are no worse than others.
# Emacs doesn't care about shadowing; see
- # <http://lists.gnu.org/archive/html/emacs-diffs/2011-11/msg00265.html>.
+ # <https://lists.gnu.org/archive/html/emacs-diffs/2011-11/msg00265.html>.
nw="$nw -Wshadow"
# Emacs's use of alloca inhibits protecting the stack.
@@ -1170,7 +1170,7 @@ dnl AC_PROG_LN_S sets LN_S to 'cp -pR' for MinGW, on the premise that 'ln'
dnl doesn't support links to directories, as in "ln file dir". But that
dnl use is non-portable, and OTOH MinGW wants to use hard links for Emacs
dnl executables at "make install" time.
-dnl See http://lists.gnu.org/archive/html/emacs-devel/2013-04/msg00475.html
+dnl See https://lists.gnu.org/archive/html/emacs-devel/2013-04/msg00475.html
dnl for more details.
if test "$opsys" = "mingw32"; then
LN_S="/bin/ln"
@@ -1316,7 +1316,7 @@ dnl Eg "make LDFLAGS=... all" could run into problems,
dnl http://bugs.debian.org/684788
dnl * unnecessary, since temacs is the only thing that actually needs it.
dnl Indeed this is where it was originally, prior to:
-dnl http://lists.gnu.org/archive/html/emacs-pretest-bug/2004-03/msg00170.html
+dnl https://lists.gnu.org/archive/html/emacs-pretest-bug/2004-03/msg00170.html
if test x$GCC = xyes; then
LDFLAGS_NOCOMBRELOC="-Wl,-znocombreloc"
else