summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-10-24 12:54:28 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-10-24 12:55:15 -0700
commit1d83257a1db3a9b87675a0dfc68cb4964cecaa09 (patch)
treeca3d11bdb03cf1591004adecb6e3596e730a369d /configure.ac
parent19667f44efabda7d4e53e706c6cd8140145b2a1a (diff)
downloademacs-1d83257a1db3a9b87675a0dfc68cb4964cecaa09.tar.gz
Port to QNX
Simplified version of a patch proposed by Elad Lahav in: https://lists.gnu.org/archive/html/emacs-devel/2017-10/msg00716.html which is based on a previous patch I proposed in: https://lists.gnu.org/archive/html/emacs-devel/2017-10/msg00707.html * configure.ac (opsys, CFLAGS, LIBS_SYSTEM, hybrid_malloc) (system_alloc, FIRST_PTY_LETTER, CYGWIN_OBJ): Set appropriately for QNX. * src/unexelf.c [__QNX__]: Include <sys/elf.h> instead of <elf.h>. (unexec): Check for sbrk failure, and fall back on old BSS end.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 646a637cf34..ca75136474e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -699,6 +699,12 @@ case "${canonical}" in
esac
;;
+ ## QNX Neutrino
+ *-nto-qnx* )
+ opsys=qnxnto
+ CFLAGS="$CFLAGS -D__NO_EXT_QNX"
+ ;;
+
## Intel 386 machines where we don't care about the manufacturer.
i[3456]86-*-* )
case "${canonical}" in
@@ -1507,6 +1513,8 @@ case "$opsys" in
hpux*) LIBS_SYSTEM="-l:libdld.sl" ;;
+ qnxnto) LIBS_SYSTEM="-lsocket" ;;
+
sol2*) LIBS_SYSTEM="-lsocket -lnsl" ;;
## Motif needs -lgen.
@@ -2210,7 +2218,8 @@ test "$CANNOT_DUMP" = yes ||
case "$opsys" in
## darwin ld insists on the use of malloc routines in the System framework.
darwin | mingw32 | nacl | sol2-10) ;;
- cygwin) hybrid_malloc=yes
+ cygwin | qnxto)
+ hybrid_malloc=yes
system_malloc= ;;
*) test "$ac_cv_func_sbrk" = yes && system_malloc=$emacs_cv_sanitize_address;;
esac
@@ -4603,7 +4612,7 @@ case $opsys in
AC_DEFINE(PTY_TTY_NAME_SPRINTF, [])
;;
- gnu | openbsd )
+ gnu | openbsd | qnxnto )
AC_DEFINE(FIRST_PTY_LETTER, ['p'])
;;
@@ -5144,6 +5153,8 @@ elif test "$opsys" = "mingw32"; then
CYGWIN_OBJ=
PRE_ALLOC_OBJ=
POST_ALLOC_OBJ=lastfile.o
+elif test "$opsys" = "qnxnto"; then
+ CYGWIN_OBJ=sheap.o
else
CYGWIN_OBJ=
PRE_ALLOC_OBJ=lastfile.o