summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan D <jan.h.d@swipnet.se>2015-04-03 18:10:27 +0200
committerJan D <jan.h.d@swipnet.se>2015-04-03 18:10:27 +0200
commit74c4ce27b510b90c29d25c462d9b84b203d00252 (patch)
tree465be24a6c2d3b8be458c0f7d81ad110d367a1d6 /configure.ac
parent5558a14438172634e8802cbaa87abc265e5d7a4c (diff)
downloademacs-74c4ce27b510b90c29d25c462d9b84b203d00252.tar.gz
Introduce limited Xpm support (32 bit ZPixmap) for Cairo.
* configure.ac (HAVE_RSVG): Move after cairo. (USE_CAIRO): Disable rsvg, don't disable Xpm. * src/image.c (prepare_image_for_display): Don't load if USE_CAIRO. (x_clear_image): If USE_CAIRO, also free possible img->ximg->obdata and don't return early. (ALLOC_XPM_COLORS): Don't define when USE_CAIRO. (xpm_load): Convert simple Xpms (32 bit ZPixmap) to CAIRO_FORMAT_ARGB32 and create a surface.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 23 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index f2cb28dba98..9d4e3758fda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2361,28 +2361,6 @@ fail;
fi
-### Use -lrsvg-2 if available, unless `--with-rsvg=no' is specified.
-HAVE_RSVG=no
-if test "${HAVE_X11}" = "yes" || test "${HAVE_NS}" = "yes" || test "${opsys}" = "mingw32"; then
- if test "${with_rsvg}" != "no"; then
- RSVG_REQUIRED=2.11.0
- RSVG_MODULE="librsvg-2.0 >= $RSVG_REQUIRED"
-
- EMACS_CHECK_MODULES([RSVG], [$RSVG_MODULE])
- AC_SUBST(RSVG_CFLAGS)
- AC_SUBST(RSVG_LIBS)
-
- if test $HAVE_RSVG = yes; then
- AC_DEFINE(HAVE_RSVG, 1, [Define to 1 if using librsvg.])
- CFLAGS="$CFLAGS $RSVG_CFLAGS"
- # Windows loads librsvg dynamically
- if test "${opsys}" = "mingw32"; then
- RSVG_LIBS=
- fi
- fi
- fi
-fi
-
HAVE_IMAGEMAGICK=no
if test "${HAVE_X11}" = "yes" || test "${HAVE_NS}" = "yes" || test "${HAVE_W32}" = "yes"; then
if test "${with_imagemagick}" != "no"; then
@@ -3111,10 +3089,10 @@ if test "${HAVE_X11}" = "yes"; then
else
AC_MSG_ERROR([cairo requested but not found.])
fi
- with_xpm=no
with_jpeg=no
with_gif=no
with_tiff=no
+ with_rsvg=no
CFLAGS="$CFLAGS $CAIRO_CFLAGS"
LIBS="$LIBS $CAIRO_LIBS"
@@ -3123,6 +3101,28 @@ if test "${HAVE_X11}" = "yes"; then
fi
fi
+### Use -lrsvg-2 if available, unless `--with-rsvg=no' is specified.
+HAVE_RSVG=no
+if test "${HAVE_X11}" = "yes" || test "${HAVE_NS}" = "yes" || test "${opsys}" = "mingw32"; then
+ if test "${with_rsvg}" != "no"; then
+ RSVG_REQUIRED=2.11.0
+ RSVG_MODULE="librsvg-2.0 >= $RSVG_REQUIRED"
+
+ EMACS_CHECK_MODULES([RSVG], [$RSVG_MODULE])
+ AC_SUBST(RSVG_CFLAGS)
+ AC_SUBST(RSVG_LIBS)
+
+ if test $HAVE_RSVG = yes; then
+ AC_DEFINE(HAVE_RSVG, 1, [Define to 1 if using librsvg.])
+ CFLAGS="$CFLAGS $RSVG_CFLAGS"
+ # Windows loads librsvg dynamically
+ if test "${opsys}" = "mingw32"; then
+ RSVG_LIBS=
+ fi
+ fi
+ fi
+fi
+
### Use -lXpm if available, unless `--with-xpm=no'.
### mingw32 doesn't use -lXpm, since it loads the library dynamically.