summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mark@klomp.org>2022-08-28 17:46:08 +0200
committerMark Wielaard <mark@klomp.org>2022-09-14 20:48:29 +0200
commit6cb01b4ef3cdd4f83d21bbcec72fa66712ac14e6 (patch)
tree5e37ea849e6d667903ff56623f5bc4ea0b8925b5 /tests/Makefile.am
parentee188125b10d1588a0536af033d7b7b1bbbaafaf (diff)
downloadelfutils-6cb01b4ef3cdd4f83d21bbcec72fa66712ac14e6.tar.gz
ar: Correct -N COUNT off-by-one
When using instance [COUNT], the instance check is wrong. instance-- == 0 should be --instance == 0. Add a testcase run-ar-N.sh that uses -N COUNT with extract and delete operations checking the right instance was extracted and deleted. https://sourceware.org/bugzilla/show_bug.cgi?id=28725 Reported-by: panxiaohe <panxh_ran@163.com> Signed-off-by: Mark Wielaard <mark@klomp.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 87988fb9..85514898 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -100,6 +100,7 @@ test-nlist$(EXEEXT): test-nlist.c
$(test_nlist_CFLAGS) $(GCOV_FLAGS) -o $@ $< $(test_nlist_LDADD)
TESTS = run-arextract.sh run-arsymtest.sh run-ar.sh newfile test-nlist \
+ run-ar-N.sh \
update1 update2 update3 update4 \
run-show-die-info.sh run-get-files.sh run-get-lines.sh \
run-next-files.sh run-next-lines.sh \
@@ -254,6 +255,7 @@ endif
endif
EXTRA_DIST = run-arextract.sh run-arsymtest.sh run-ar.sh \
+ run-ar-N.sh \
run-show-die-info.sh run-get-files.sh run-get-lines.sh \
run-next-files.sh run-next-lines.sh testfile-only-debug-line.bz2 \
run-get-pubnames.sh run-get-aranges.sh \